Sudo 缓冲区错误漏洞(CVE-2022-43995)

piaoling  2023-11-09 14:22:03
一、查看sudo版本

sudo -V

二、下载最新版本到服务器并解压

wget https://www.sudo.ws/dist/sudo-1.9.15.tar.gz && tar -zxvf sudo-1.9.15.tar.gz



三、安装
1、执行配置命令

cd sudo-1.9.12p1 && ./configure --prefix=/usr  --libexecdir=/usr/lib  --with-secure-path  --with-all-insults  --with-env-editor  --docdir=/usr/share/doc/sudo-1.9.15 --with-passprompt="[sudo] password for %p: "

可能需要依赖编译器
yum install gcc-c++
2、编译安装

make && make install && ln -sfv libsudo_util.so.0.0.0 /usr/lib/sudo/libsudo_util.so.0

四、再次查看sudo版本

sudo -V


类别 :  默认(739)  |  浏览(265)  |  评论(0)
发表评论(评论将通过邮件发给作者):

Email: